Missing: Previous Next

Follow the adventures of Rosencrantz and Guildenstern Fran and Naga in this all-new humorous entry to the growing Poeverse.

Re: Missing: Previous Next

Postby kaitou » January 12th, 2011, 9:20 pm

KZK wrote:The "First" Image link is fine (an image of a white box with the word "First"). The Prev/Next/Last images are solid Black. This is probably a transparency issue (it has black text and a transparent background, which means, in my case solid black as the default background color on my computer is black; This is actually a common mistake many programmers make: Always set both foreground and background colors or you will get problems). The other black boxes in between appear to be links to other things or javascript, are also solid black. Also a solid black link at the bottom of the blog posting.

But the links work, so, fixed.


Odd. I would think that transparency should show the image behind it, and in this case, it should be the white background in the window, unless you have background images turned off. The "first" image is also a transparency (otherwise, we couldn't see the rollover image behind it); so, I don't know why only it has a white background.

The four links in the middle are, a facebook link (for the "like" feature), the share javascript link, comment link to the forum thread for that comic and a link for buying a print of that comic. The only one of those you might be interested in is the comment link.
User avatar
kaitou
Almighty Systems Admin
 
Posts: 262
Joined: January 18th, 2008, 12:41 pm
Location: In the dark digital recesses of your mind.
Twitter @: kaitou_

Re: Missing: Previous Next

Postby KZK » January 12th, 2011, 10:24 pm

kaitou wrote:Odd. I would think that transparency should show the image behind it, and in this case, it should be the white background in the window, unless you have background images turned off.


You would be wrong. It is actually using the background color from the 3D Objects attibute in windows itself ("Color 1"). (I don't have background images turned off in the unfiltered version).

kaitou wrote: The "first" image is also a transparency (otherwise, we couldn't see the rollover image behind it); so, I don't know why only it has a white background.


I don't know why the first one shows up correctly. I have screenshots of the others when I futzed around with Windows colors.

But this is why it is never a good idea to do things with transparency. You don't know how it's being handled in a bazillion different programs with a bazillion different settings. (FREX: Windows Picture and Fax viewer uses a different setting, the Windows background color (Color 1) to display transparent images).
KZK
Forum Trainee
 
Posts: 18
Joined: October 10th, 2009, 1:25 am

Re: Missing: Previous Next

Postby RGE » January 17th, 2011, 5:29 pm

Speaking of buttons, the navigation buttons under the comic looked fine before, but now they seem to be pushed together so that three of them end up directly below three of the other buttons: Previous is under First, Shop is under ShareThis, and Last is under Next. I use Opera to browse, and my screen resolution is 1024 x 768.

KZK wrote:I'd have to install software to get a screencap, and it would have to be software that doesn't require a restart (win XP). It's been years since I've needed something like that, so I don't know all the current freeware that does things like that.

PrtScrn-button + MS Paint? Or IrfanView, which I'm pretty sure doesn't require a restart.

(I know this is no longer an issue, but it made me curious that someone with Windows would need extra software just to get a screencap. Related story: A guy once sent me a digital photo of a screen desktop that his dad had sent to him. I'm sure his dad got to hear about the PrtScrn-button.)
User avatar
RGE
Errant Scholar
 
Posts: 158
Joined: November 2nd, 2007, 6:31 pm
Location: Karlstad, Sweden

Previous

Return to Does Not Play Well With Others

Who is online

Users browsing this forum: No registered users and 2 guests